My World GIS
My World GIS
    My World GIS | Help | Login | Logout |                Logged in as:

 Frequently Asked Questions

  If you don't see your question here, please email info@myworldgis.org


Can I  import data from a GPS device?


Yes, there are several different ways to import from a GPS: 

1.  If you have a Garmin GPS device with a serial connector, you can download your way points directly from the GPS device into My World.  Simply connect the device to your computer, and then select "Import layer from GPS" in the "File" menu.  My World will download the waypoints and then create a new layer to store them. 

You must save the new layer in a project or as a separate layer file if you want to keep it for future use. 

Notes:

  • To import directly into My World, you must use a serial cable connected to the serial out of your Garmin device, even if your GPS and computer have USB .
  • If you're using a Mac, you must use a serial-to-USB converter to connect the serial cable to your computer. 
  • My World is only compatible with Garmin GPS devices.  Support for other devices will be available in a future version. 
  • My World can only import waypoints currently.  Support for track will be available in a future version. 

2.  You may use the software that came with your GPS device or any number of freeware or shareware programs to upload your GPS data to your computer, and then import it into My World.  To import a waypoint file into My World, you should either save it as a GPX file or as a comma- or tab-separated-values text file.  You can then import those files into My World using the "Import Layer from File" command. 

3.  If you are using a GPS together with Vernier's Logger Pro® software to collect sensor data with latitude and longitude values, you can export your data file from Logger Pro® using the "File>Export As...>GPS Format" command and then import that file directly into My World using the "File>Import Layer from File" command. 

My World's "data" folder on my students' computers is locked by the administrator, and I do not have access to it.  How can I put data on their computers and have My World find the data at startup?


There are a couple of solutions to this problem:

1. In most cases, the best solution is to create a "My World data" folder somewhere that you and/or your students can save and modify files.  Often this is somewhere in the home directory for student accounts.  Then using the "Edit>Preferences..." menu option, add that directory to the "Folders to Search for Data at Startup" list.  This will cause My World to search that directory for data and projects every time it launches.  Any data or projects it finds will be added to the appropriate lists in the data library that is visible in "Construct" mode.      

If the computers will be connected to a server when students are using them, you could add a directory on that server to  to the "Folders to Search for Data at Startup" list as well.  That way you can add projects and data for students to access at any time.
2.  A second solution is to put the projects and data on a CD or server and have students use "File>Index Folder" to index the contents of the CD or serever directory at the beginning of each session.  This does not have the advantage of enabling My World to automatically find the data every time it launches, but it also gives the flexibility to put the data in different locations at different times and not have to mess around with preferences each time. 
I'm using a Mac and when I download a zip file with projects in it, the projects appear as folders instead of .m3vz files. 

What you're seeing is a result of the mac unzip utility in the MacOS being too smart for its own good.  When the mac is expanding the zip files, it is seeing that the .m3vz files are compressed files in zip format, and it is automatically expanding them as well. 

For example, instead of seeing a file called "Climate_Change_Greenland.m3vz" you are seeing a folder with the name:  Climate_Change_Greenland with a settings.mvf file and a whole lot of other files inside it. 

One way to overcome this problem is to find the original .zip file that you downloaded.  Double-click on the .zip archive to expand it.  It will expand first into a ".m3vz" file and then expand that .m3vz folder into the a similarly named folder.  Delete the folder and work with the .m3vz file.  You need to do this re-expansion because when browsers automatically expand a .zip file, they will delete the intermediate .m3vz file. 

We apologize for this problem, but it's out of our control.  It's the behavior of the zip expansion utilities.


How do I convert a data field that is made up of categories to numbers? 

If you have a table with categorical data in one column (field), and you want to be able to convert it to numbers so that you can do quantitative operations on it, you can make the conversion with the following sequence of steps:

Step 1: Create a new field with the text names of categories replaced by numbers:
  1. Click on the "analyze" tab to enter analyze mode.
  2. Select "Add field to layer by...Re-classifying"
  3. Select the layer and field that you want to convert from categories to numbers.
  4. In the "Name" column of the table, type in the number that you want to use in place of each category.  (You can combine more than one category by control-clicking all the categories and then selecting "merge categories". 
  5. Name the new field and click "OK" to create the new field and return to "Visualize" mode.

Step 2: Until you tell it otherwise, My World will assume the new field consists of text categories.  To tell My World that the new field should be treated as numbers, not text:
  1. In visualize mode, click on the layer with the new field in the layer list to make it the "active" layer.
  2. In the "Layer" menu at the top of the window, select "Edit Layer Information".  This will bring up a window that provides My World with information about how to interpret and display the data.
  3. Click on the "Fields" tab in the "Edit Layer Information"  window.
  4. Find the column in the table with your new field in it.  The data type for that column will say "Text".
  5. Click in the "Effective Data Type" row for your new field.  A menu will pop up.  Select "Number".  My World will now recognize the data in that field as numerical. 
  6. If you want to display the data with units or in a special format (e.g., as a date or in scientific notation), then you will need to save the layer in a file first and re-open it within My World.  At that point, you can return to the "Edit Layer Information" for that layer and change the Units and/or Format.

I changed the transparency of one of my Layers, now it seems to have disappeared. Where did it go?

If you set the transparency of a Layer to 100%, it will not appear at all; the Layers beneath it will show through completely. To see the Layer again, set its transparency to a value less than 100%.


I'm trying to enter a value into a table (in the Layer Appearance Window, the Layer Information Window, or the Edit Table Panel), but every time I finish typing and click somewhere else, it goes back to its original value. What gives?

Some Java implementations require that you press Return or Enter when you are editing a table before you click elsewhere, or the changes will not "stick". Try pressing Return or Enter after making your changes.


I'm trying to enter a Date or Time in Edit mode, and My World keeps telling me that the value I'm entering doesn't appear to be a Date. How I make this work?

My World prefers Date and/or time values in ISO 8601 format, but it will accept values in any of the following formats:

1. y year only, any number of digits, negative values for BCE
2. y e year followed by era (BC/AD or BCE/CE)
3. yyyy-mm-dd ISO 8601 year-month-day format
4. m/d/y month/day/year, any number of digits, separated by "/"
5. hh:mm:ss hours:minutes:seconds, two digits apiece, separated by ":"
6. hh:mm:ss am/pm same as above, plus "am" or "pm"
7. hh:mm hours:minutes, two digits apiece, separated by ":"
8. hh:mm am/pm same as above, plus "am" or "pm"
9. #2 or #3 above followed by any of #5-8

Times you enter are assumed to be in the local time zone. My World stores times internally in Coordinated Universal Time (UTC), and always displays them using the local time zone.

Can I put images on my Map?


Yes! As of Version 3.0 My World does support images. See Section 12: Importing Image Data of the My World documentation page for information on how to import new images data My World.

 

How can I put labels on my Map?


Go to Edit Mode and click the "New Layer..." button. Select "Annotation" as the type of the new layer, then either select the Layer or Selection you want to label, or simply click OK, then create the labels one-by-one. See Section 9: Editing Annotation Layers of the My World documentation page for more information on how to do this.

What is a projection and why is My World asking for the projection for my data?

A map projection converts three-dimensional geographical coordinates to two-dimensional pictures on your computer screen.  Dfferent projections will have different effects on the representation of your data.  My World is asking you to choose how you want your data to appear as a map.  For more on map projections and selecting the best projection for your data see "Map Projection Basics."


Can I export a WorldWatcher grid file to ArcGIS rasters?
Unfortunately the ArcGIS raster format is proprietary, so we aren't able to support reading or writing ArcGIS rasters. However, My World can save grids in ESRI ASCII format, which can be imported into ArcGIS and most other professional GIS applications.
To do so, select the layer in the layer list, then choose "Save Layer As..." from the "Layer" menu. Then select "ESRI ASCII Grid" as the file format in the dialog's "Save As:" menu. Note that the ASCII grid option is not available for grids that have categorical fields, because the ASCII grid format only supports numeric values.

Note that it is possible to convert categorical fields to numeric fields, but the process is a little involved. First, use the "Add Field(s) To Layer-> By Reclassifying" analysis tool to create a new field that replaces the names of your categories with numbers. The new field will still be a categorical field, but you can change it to a numeric field using the Fields tab of the Edit Layer Information window (available from the Layer menu) to change the field's effective type from "Text" to "Number". Then, you can delete the categorical version of the field by selecting "Delete Field..." from the "Layer" menu, and you'll be able to save the numeric version as an ASCII grid.


How do you cache or save dynamic web layers so they can be used while working offline?
Select the WMS layer in the Layer List, then use "Save Layer As..." in the "Layer" menu to save the layer as a JPEG. You'll need to select "JPEG Image File" from the menu in the "Save Layer As" dialog, as it defaults to "WMS Service."



 



Last Updated: 2010-01-04 15:12:39


Home | Project Overview | Curriculum | Software | Download the Software
Research & Publications | Conferences & Presentations | Recognition | Who We Are | Site Map